• Resolved tictok

    (@tictok)


    Hi –

    I’m using Order Splitter for WooCommerce to automatically split orders when they contain specific products.

    In our WooCommerce store we use both Stripe and Paypal as payment gateways, giving the customer the choice at the checkout.

    Order Splitter works great with Stripe, but when a customer pays for an order using PayPal, the order gets split as it should but the order ‘parts’ are not given the correct order status.

    I have a custom order status called ‘Parent Order’. When an order gets split, the original order is given the status of ‘Parent Order’. (‘Parent Order’ isn’t included in revenue reports or exported to fulfilment) and the split parts of the order should be given the ‘Processing’ status as the order has been paid for. These split parts are included in reports and sent to fulfilment.

    However when a customer uses PayPal, the ‘Parent Order’ status isn’t applied (instead it has the ‘Processing’ status) and the split order parts are given the ‘Pending’ status (when it should be ‘processing’ status).

    The issue only occurs when a customer pays using PayPal. It works great when they pay by card using Stripe.

    I’ve tried various things, and changing the hook that’s used (in the Cron Jobs / Action Hooks’ tab), but can’t manage fix the problem.

    Is it something you are aware of? Perhaps it’s to do with how the PayPal payment works (as the customer is taken to Paypal, and then back to the site).

    It’s strange, because the order is split correctly, but all the parts or the order (both original and split parts) have incorrect order statuses.

    I hope that makes sense and hope you might be able to suggest a fix or work around?

    Many thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Problem

    Order Splitter works great with Stripe, but when a customer pays for an order using PayPal, the order gets split as it should but the order ‘parts’ are not given the correct order status.

    Diagnosis

    Buyer is coming back to your thank you page after payment? It is important if buyer comes back, else splitter will miss the trigger which is required to split.

    Solution

    You have already tried the hooks but hooks are still dependent on trigger. Did you try cron job thing? Hooks tab is having checkboxes and a cron job URL thing as well.

    1) First solution is, you try through PayPal and then access the URL given under hooks/cron job tab if order get splitted and statuses set correctly? You can use that cron job thing with a specific interval.

    2) Reach me through my demo website setup for testing. And i will invite you as an admin user on my website to create the same scenario for improvement.

    Thanks
    Fahad

    • This reply was modified 4 years, 4 months ago by Fahad Mahmood.
    Thread Starter tictok

    (@tictok)

    Hi – thanks for your reply Fahad,

    I’ll come and contact you through your demo website (although might not be until early next week). Thanks.

    To be clear though, as I think I might have confused things:

    Orders payed for using Paypal ARE being split as expected.
    However they are not receiving the correct order statuses.

    This happens even when the user gets sent back to the site from Paypal. The orders also appear split as expected on the Thank You page. We currently use standard PayPal, but we just signed up from PayPal by Braintree. That takes a few days for them to authorise our company before we can use it, so will test with that too next week.

    Many thanks
    Stef

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Dear Stef,

    My guess is, as plugin requires a trigger like from on-hold to processing mostly. And from processing to completed. Maybe you need to TURN all these three triggers ON from hooks tab as we don’t know that when PayPal will confirm the payment and pingback your online WooCommerce based store for that particular ORDER. Whenever it will happen, statuses will be updated according to split.

    Here is another thought, as my plugin updates statuses only during splitting process. So as you are mentioning that split is working but but not status updates. It means, at that time parent order is having some different status and same is being cloned to child. Anyways, i will check your form submission regarding demo website and will check this issue with you.

    Thanks,
    Fahad

Viewing 3 replies - 1 through 3 (of 3 total)
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